首页 » 计算机网络辅导 » 计算机网络代写 | CETM51 – Computer Architectures & Networks

计算机网络代写 | CETM51 – Computer Architectures & Networks

这个作业是使用VLSM创建IPv4方案以适应所示的整个网络
CETM51 – Computer Architectures & Networks
Assignment 2 of 2
The following outcomes will be assessed:
Knowledge
 An appreciation and configuration of the hardware devices of a network system using
standard network models, protocols and media.
Skills
 The ability to assemble, configure and operate a network system and apply security measures
to it.
Important Information
You are required to submit your work within the bounds of the University Infringement of Assessment
Regulations (see your Programme Guide). Plagiarism, paraphrasing and downloading large amounts
of information from external sources, will not be tolerated and will be dealt with severely. Although
you should make full use of any source material, which would normally be an occasional sentence
and/or paragraph (referenced) followed by your own critical analysis/evaluation. You will receive no
marks for work that is not your own. Your work may be subject to checks for originality which can
include use of an electronic plagiarism detection service.
Where you are asked to submit an individual piece of work, the work must be entirely your own. The
safety of your assessments is your responsibility. You must not permit another student to access your
work.
Where referencing is required, unless otherwise stated, the Harvard referencing system must be used
(see your Programme Guide).
Please ensure that you retain a duplicate of your assignment. We are required to send samples of
student work to the external examiners for moderation purposes. It will also safeguard in the unlikely
event of your work going astray.
Submission Date & Time 8
st May 2020 by Midnight (Part A Only)
Submission Location By electronic submission via Canvas
CETM51 Network Implementation Assignment
Instructions:
In teams of no more than four students (one network domain each) you are required to build and test
the following network. Part A is to be done in your own time prior to your implementation session.
Part B is to be done in a practical session – as defined by your tutor.
The ISP router at the centre of the network shown above has already been configured. All that is
needed is the correct serial line connection to your local router. ALL serial interfaces that are under
your administrative control and are connected to the ISP should be set up as “DTE” enabled interfaces.
All network domains must use the OSPFv2 or OSPFv3 routing protocol in network area 0.
The diagram for this assignment can be found in the accompanying file on your Canvas site for CETM51
– CETM51Assignment2Diagram.pdf
Your Part A section must very clearly indicate which network domain you have selected, and should
also show which other group members have taken the other domains.
Part A – Individual Submission:
1. Create an IPv4 scheme using VLSM to cater for the whole network shown – use a separate
private address range for each area. You must show ALL working out! You are to ensure that
IP address wastage is kept to an absolute minimum.
[25 Marks]
2. Apply the IPv4 addressing scheme to a copy of the diagram.
[5 Marks]
3. Create an IPv6 scheme that could be used in place of the IPv4 scheme. Use appropriate
address types with brief reasoning as to why you make your choices.
[20 Marks]
4. Apply the IPv6 addressing scheme to another copy of the diagram.
[5 Marks]
Part B – Practical Simulation:
Build the network you have been given in the diagram on Packet Tracer. The configuration for the ISP
router has been provided for you below.
1. Basic Network Configuration: Build your network as shown on your network diagram. This
part of the configuration should include all hostnames, interfaces and their IP addressing and
OSPF dynamic routing protocol and any necessary static or default routesto get your network
areas to communicate (you should only be able to ping border addresses at this point) –
ensure these are redistributed.
[15 Marks]
2. Network Enhancements: Configure NAT and PAT on all the border routers and employ Static
NAT for the WWW server.
[10 Marks]
3. Network Security Tasks: Given the GRE tunnel map you are provided with, set this up and
add it to your routing protocol configuration – OSPF should also authenticate itself with the
appropriate pre-shared key – use banana for this. Add an IPSec point-to-point VPN between
two of the network areas. It is up to you which you choose.
[20 Marks]
Configuration for ISP Router:
Use a 2811 router and install 4 WIC-1T serial ports in the four vacant slots before configuring it with:
enable
configure terminal
hostname ISP
interface s0/0/0
ip address 1.0.0.1 255.255.255.240
clock rate 64000
no shutdown
interface s0/1/0
ip address 2.0.0.1 255.255.255.240
clock rate 64000
no shutdown
interface s0/2/0
ip address 3.0.0.1 255.255.255.240
clock rate 64000
no shutdown
interface s0/3/0
ip address 4.0.0.1 255.255.255.240
clock rate 64000
no shutdown
exit
ip route 1.0.0.0 255.0.0.0 s0/0/0
ip route 2.0.0.0 255.0.0.0 s0/1/0
ip route 3.0.0.0 255.0.0.0 s0/2/0
ip route 4.0.0.0 255.0.0.0 s0/3/0
exit


程序辅导定制C/C++/JAVA/安卓/PYTHON/留学生/PHP/APP开发/MATLAB


本网站支持 Alipay WeChatPay PayPal等支付方式

E-mail: vipdue@outlook.com  微信号:vipnxx


如果您使用手机请先保存二维码,微信识别。如果用电脑,直接掏出手机果断扫描。

blank

发表评论

您的电子邮箱地址不会被公开。